NixToSee/modules/sec_auth/ssh.nix

27 lines
890 B
Nix

{pkgs, ...}: {
programs.ssh = {
startAgent = true;
enableAskPassword = true;
#askPassword = "${pkgs.ssh-askpass-fullscreen}/bin/ssh-askpass-fullscreen";
askPassword = "${pkgs.lxqt.lxqt-openssh-askpass}/bin/lxqt-openssh-askpass";
};
# This is using a rec (recursive) expression to set and access XDG_BIN_HOME within the expression
# For more on rec expressions see https://nix.dev/tutorials/first-steps/nix-language#recursive-attribute-set-rec
environment.sessionVariables = {
SSH_AUTH_SOCK = "$XDG_RUNTIME_DIR/ssh-agent";
};
environment.systemPackages = with pkgs; [
#ssh-askpass-fullscreen
lxqt.lxqt-openssh-askpass
];
# Some programs need SUID wrappers, can be configured further or are
# started in user sessions.
# programs.mtr.enable = true;
# programs.gnupg.agent = {
# enable = true;
# enableSSHSupport = true;
# };
}